Marrow works on mobiles and tablets with Android version 5.1 & above or iOS version 11 & above. However, we do not have a list of foolproof devices.

We have instituted several security measures such as Digital Rights Management (DRM), Google SafetyNet, which also prevents rooted devices. Before purchasing the device, please make sure the device supports WIDEVINE L1.

Please go through the list of known device issues before purchasing a device: https://www.marrow.com/blog/known-device-specific-video-issues-in-marrow/.